Búsqueda personalizada

12 marzo 2007

Gtalk para linux?? Voip en Tapioca

Vivís a caballo entre Linux y Windows. Google es para vosotros como el hermano que el hijo único nunca tuvo. Habéis conocido a Gtalk y cuando váis de viaje al mundo OpenSource os sentís desprotegidos... Seguid rezando porque, que yo sepa, todavía no tenemos cliente para plataformas Linux.
Sin embargo, y si lo que más echáis en falta de ese servicio es la funcionalidad VoIP, que sepáis que existe una aplicación que, basándose en la atractiva imagen de Gtalk, nos ofrece la posibilidad de ponernos en contacto con los nuestros de esta forma.
Tapioca es un proyecto que sigue los estándares del proyecto Telepathy para establecer la conexión sobre cuentas MSN, IRC, Jabber, ... Junto a esta especificación, y mediante el uso de librerías C#, Glib, Qt, permite, además, la convivencia de la mensajería instantánea con la llamada de voz a través de VoIP.
Hay que decir que este proyecto está en continua evolución, y para poder disfrutar de la versión actual es necesario visitar la página de Tapioca Proyect.

No obstante, y si eres usuario de la última versión de Ubuntu (Edgy 6.10), instala este paquete (todos sus ficheros, mediante algún gestor de instalación como Gdeb, si no quieres complicarte la vida), y ten en cuenta que debes cubrir todas las dependencias.
Estas dependencias puedes satisfacerlas mediante el comando:

sudo aptitude install libdbus-1-dev libdbus-glib-1-dev libglib2.0-dev libssl-dev libexpat1-dev libasound2-dev

Posiblemente, y dado que las versiones tal vez no sean estables, al lanzar tapioca (tapiocaui), puede sorprenderte el siguiente mensaje de error:

kayak@HR24:~$ tapiocaui
tapiocaui: error while loading shared libraries: libdbus-1.so.2: cannot open shared object file: No such file or directory

El problema está en que tapioca intenta buscar la referencia a la librería dinámica, y no la encuentra, debido a que el nombre de la versión no es la adecuada. Crearemos entonces un enlace a la librería que nosotros tenemos mediante:

kayak@HR24:~$ locate libdbus-1.so
/usr/lib/libdbus-1.so.3
/usr/lib/libdbus-1.so.3.0.0
sudo ln -s /usr/lib/libdbus-1.so.3.0.0 /usr/lib/libdbus-1.so.2

Si todo ha salido correctamente, podremos lanzar el programa mediante el comando tapiocaui.

Blogalaxia Tags:
Blogalaxia Tags:

No hay comentarios: